12. СЕРВИС

Содержание...

Назначение:
В системе предлагается ряд операций, позволяющих пользователю настраивать систему. С помощью этих операций осуществляется настройка интерфейса системы, справочников, тарифной сетки и склонений для печати. Эти операции выделены в отдельную папку настроек.

Вызов:
Меню → Сервис → Настройки.

Персонал-Биз Персонал-Про



Рисунок 12.1. Меню "Настройки" системы "Персонал-Биз"



Рисунок 12.2. Меню "Настройки" системы "Персонал-Про"

12.1 Настройка фирмы

Назначение:
Операция "Настройка фирмы" служит для создания новой фирмы, настройки параметров документов для ведения кадрового учета фирмы (список рассылки, визы на документах, префикс и нумераторы) и администрирования по фирме (доступ пользователей до редактирования данных о фирме).

Вызов:
Меню → Сервис → Настройки → Настройка для фирмы.

Закладки диалога:
Закладка Назначение
Общие настройки фирмы
Пользователи
Печать (настройки виз и рассылки)
Нумераторы
Дополнительные настройки

Поля диалога:
Поле Назначение
Фирма Список активен только в версии "Персонал-Про". Позволяет переключиться на другую фирму в режиме многофирменности.

Кнопки диалога:
Кнопка Название Функция
Добавить фирму Активна только в версии "Персонал-Про". Служит для выбора фирмы, а также для добавления новой фирмы в режиме многофирменности.
Сохранить Сохраняет изменения, внесенные в настройки фирмы (измененные поля выделяеются розовой заливкой).
Выйти Выход из диалога.

Результат:
По кнопке "Сохранить" настройки фирмы сохраняются в системе.

12.1.1 Общие



Рисунок 12.1.1 Диалог "Настройка фирмы", закладка "Общие"

Поля диалога:
Поле Назначение
Название общепринятое Общепринятое наименование организации.
Название полное Полное название организации, которое будет отображаться в заголовке отчетов при печати отчетных документов.
Название сокращенное Сокращенное название организации, достаточное для ее полной идентификации. Под этим названием организация будет известна в системе, оно будет отображаться на панелях, в карточках и диалогах.
Код ОКПО Код по Общеросиийскому классификатору предприятий.
Префикс документов Активно только в версии "Персонал-Про". Установленный префикс документов для данной фирмы в режиме многофирменности. В это поле записывается префикс, который будет вводиться для всех документов (приказов) данной фирмы. При работе с несколькими фирмами указание префикса обязательно.
Право использования программы Сведения о регистрации программы.

Кнопки диалога:
Кнопка Название Функция
Зарегистрировать программу Открывает диалог "Регистрация системы".

12.1.2 Пользователи

Назначение:
Закладка «Пользователи» предназначен для создания списка пользователей, которым разрешен доступ в систему.



Рисунок 12.1.2 Диалог "Настройка фирмы", закладка "Пользователи"

Поля диалога:
Поле Назначение
Доступ пользователей к фирме Перечень пользователей.
Новый пользователь Выбрать из списка пользователя. Пользователями программы могут быть только сотрудники организации, принятые на работу или оформленные как кандидаты!
логин Ввести новый логин.
пароль Ввести новый пароль.
роль Выбрать роль администрирования.

Кнопки диалога:
Кнопка Название Функция
Добавить пользователя Создает нового пользователя в системе.
Удалить пользователя Открывает диалог "Регистрация системы".

Для добавления нового пользователя необходимо из списка выбрать сотрудника Новый пользователь, заполнить поля логин и пароль, выбрать роль и нажать . Хотя бы один пользователь должен иметь доступ к фирме для ведения ее кадрового учета.

12.1.3 Печать



Рисунок 12.1.3 Диалог "Настройка фирмы", закладка "Печать"

Поля диалога:
Поле Назначение
Визы на документах Таблица, предназначенная для внесения виз ответственных лиц. В первой колонке указывается вид документа, во второй - выбирается сотрудник, в третьей - выбирается должность.
Рассылка по умолчанию Список подразделений для рассылки.

Кнопки диалога:
Кнопка Название Функция
Изменить Открывает справочник "Рассылка документов".
 
Вверх/Вниз Изменение последовательности рассылки.

В левой области отмечаются визы, которые будут отражены по умолчанию в диалоге создания черновика приказа (при необходимости список можно будет изменить при создании конкретного приказа). Добавление и изменение значений в списке виз осуществляется через выпадающее меню по правой кнопке мыши на таблице с визами (рис.12.1.3). Виза с типом "на справке" используется только при печати справки с места работы.

В правой области отмечаются виды рассылки из справочника, которые будут отражены по умолчанию в диалоге создания черновика приказа (при необходимости список можно будет изменить при создании конкретного приказа). Добавление новых значений в список рассылок осуществляется через операцию "Cправочник характеристик" или из выпадающего меню по правой кнопке мыши на таблице с рассылкой.

12.1.4 Нумераторы



Рисунок 12.1.4 Диалог "Настройка фирмы", закладка "Нумераторы"

Поля диалога:
Поле Назначение
Нумератор табельных № Выбрать нумератор из списка для табельных номеров.
Нумератор приказов Выбрать нумератор из списка для приказов.
Нумератор трудовых договоров Выбрать нумератор из списка для трудовых договоров.
Нумератор гражданско-правовых Выбрать нумератор из списка для ГПД.

Кнопки диалога:
Кнопка Название Функция
Настройка нумераторов Открывает диалог "Настройка нумераторов" для создания и редактирования нумераторов.

Из справочника выбираются нумераторы. При регистрации документа (приказа) номер будет присваиваться автоматически в порядке возрастания. Для перехода к менеджеру нумераторов служит кнопка .

12.1.5 Дополнительные



Рисунок 12.1.5 Диалог "Настройка фирмы", закладка "Дополнительные"

На данной закладке производятся различные настройки фирмы.

12.2 Настройки кадрового учета

12.2.1 Восстановление закладки ”сотрудники” в подразделениях

Назначение:
Служит для добавления (восстановления) закладки "сотрудники" в карточке подразделения. Эту операцию рекомендуется выполнять в случае, если Вы самостоятельно в карточке сотрудника изменили параметры назначений, для того, чтобы эти изменения отразились в описаниях подразделений.
Если в процессе работы системы осуществлялись назначения или увольнения непосредственно через карточки сотрудников, то между данными карточек сотрудников и данными карточек подразделений может возникнуть несоответствие. Для устранения такого несоответствия предназначена операция «Восстановление закладки «сотрудники» в подразделениях».

Данная операция требуется в том случае, когда сотрудника принимают на работу будущим числом!

Вызов:
Меню → Сервис → Настройки → Восстановление закладки 'сотрудники' в подразделениях.

В процессе выполнения операции данные по подразделениям будут согласованы с данными в карточках сотрудников.



Рисунок 12.2.1. Процесс выполнения операции «Восстановление закладки «сотрудники» в подразделениях»

12.2.2 Генерация ссылок на фотографии

В разработке!

12.2.3 Настройка порядка подразделений

Назначение:
Операция «Настройка порядка подразделений» позволяет изменять последовательность отображения на панели объектов подразделений, входящих в данное подразделение.

Вызов:
Меню → Сервис → Настройки → Настройка порядка подразделений.

При выборе операции система предлагает диалоговое окно для настройки порядка подразделений (см. рисунок 12.2.2). Диалог настройки порядка подразделений позволяет изменить порядок следования подразделений на панели объектов для удобства работы.



Рисунок 12.2.2. Настройка порядка подразделений

Кнопки диалога:
Кнопка Название Функция
Обновить Обновляет содержимое окна
Сохранить Сохраняет установленный порядок подразделений.
 
Вверх/вниз Перемещают выделенное подразделение в соответствующем направлении.
Выход Закрытие окна «Настройка порядка подразделений».

Для изменения позиции отображения подразделения выделите это подразделение в таблице, а затем с помощью стрелок вверх и вниз, передвиньте его в необходимую позицию и сохраните изменения, нажав на кнопку .

12.2.4 Настройка тарифной сетки

Назначение:
Операция "Настройка тарифной сетки" позволяет редактировать тарифную сетку предприятия.

Вызов:
Меню → Сервис → Настройки → Настройка тарифной сетки.

При выборе операции система предлагает диалоговое окно для настройки тарифной сетки (см. рисунок 12.2.3).



Рисунок 12.2.3. "Настройка тарифной сетки"

По умолчанию оклад по ПКГУ/разряду рассчитывается как минимальная тарифная ставка, умноженная на коэффициент для данного ПКГУ/разряда.
Для изменения значений коэффициента или оклада по ПКГУ/разряду, выберите в таблице нужное поле (коэффициент или оклад) напротив ПКГУ/разряда, который нужно изменить. При двойном щелчке на выбранном поле оно переходит в режим редактирования. Измените значения, и нажмите клавишу "Сохранить".

Добавление нового тарифного разряда (например, 19) осуществляется через операцию "Справочник характеристик".

Внимание. Изменение тарифной сетки не приводит к автоматическому изменению окладов в штатном расписании и в назначениях у сотрудников. Для приведения штатного расписания и назначений сотрудников в соответствии с новой тарифной сеткой можно использовать операции:
"Корректировка текущего ШР в соответствии с тарифной сеткой"
"Корректировка планируемого ШР в соответствии с тарифной сеткой"
"Корректировка назначений в соответствии с тарифной сеткой"

12.2.5 Проверка должностей со степенью

Назначение:
Данная операция является проверочным отчетом в Microsoft Excel, целью которого является проверка наличия сведений о дипломе кандидата/доктора наук на закладке "наука" электронной карточки у работающих сотрудников, имеющих у параметра "должность/профессия" значение, содержащее "к.н." или "д.н.".

Вызов:
Меню → Сервис → Настройки → Проверка должностей со степенью.



Рисунок 12.2.4. Проверка должностей со степенью

12.2.6 Проверка соответствия назначений штатному расписанию

Назначение:
Операция «Проверка соответствия назначений штатному расписанию» позволяет выявить несоответствия между текущим штатным расписанием и текущими назначениями сотрудников. Эта операция также позволяет отобразить в формате Microsoft Word или Microsoft Excel текущее штатное расписание и (или) списки работающих сотрудников по подразделениям. Список подразделений отсортирован по алфавиту, но первым всегда отображается подразделение с некорректными назначениями.

Вызов:
Меню → Сервис → Настройки → Проверка соответствия назначений штатному расписанию.

При выборе операции система предлагает диалоговое окно для задания необходимых параметров (см. рисунок 12.2.5).



Рисунок 12.2.5. "Проверка соответствия назначений штатному расписанию"

Поля диалога:
Поле Назначение
# Для подразделения В этом поле из выпадающего списка выбирается подразделение, для которого будет выполнена проверка.
С вложенными Пометка в этом поле обеспечит вывод информации не только для выбранного подразделения, но и для подчиненных ему подразделений (если они есть).
Вывод результатов: Word Пометка в этом поле обеспечит вывод результатов операции в необходимом формате:
Word;
Excel.
Отображать только подразделения с ошибками Пометка в этом поле обеспечит вывод информации только по подразделениям, содержащим ошибки. Уровень проверки задается в полях «проверять соответствие назначений ШР» и «проверять соответствие надбавок ШР»
Отображать информацию о штатном расписании Пометка в этом поле обеспечит вывод информации о текущем штатном расписании подразделения с указанием количества занятых и вакантных ставок.
Отображать информацию о сотрудниках Пометка в этом поле обеспечит вывод информации о сотрудниках.
Проверять соответствие назначений ШР Пометка в этом поле обеспечит проверку соответствия назначений сотрудников штатным позициям в текущем ШР.
Проверять соответствие надбавок ШР Пометка в этом поле обеспечит проверку соответствия надбавок к назначениям сотрудников надбавкам по штатными позициями в текущем ШР.
Примечание: см. используемые в таблице символы.

Результат:
Печатный отчет в формате Microsoft Word или Microsoft Excel с указанием ошибок для выбранного подразделения в соответствии с выбранными параметрами.

12.2.7 Операция "Настройка отчетов по ШР" PRO

Назначение:
Для настройки отчетов по ШР, используется специализированный диалог, позволяющий изменять информацию, необходимую для формирования отчета.

Вызов PRO:
Меню → Отчеты → Отчеты по численности, далее выбрать один из отчетов:
  • Средняя численность за месяц;
  • Средняя численность совместителей за месяц.
    Затем нажать кнопку .
  • При нажатии кнопки открывается диалог настройки отчета (рисунок 12.2.6).



    Рисунок 12.2.6. Диалог настройки отчета

    Знаком "+" обозначены параметры отчета, значения которых могут изменяться пользователем. При нажатии левой кнопкой мыши на "+", открываются значения соответствующей характеристики, доступные для изменения.

    Поля диалога:
    Поле Назначение
    Выпадающий справочник Справочник позволяет устанавливать значения характеристик для формирования отчета. При этом можно изменить установленные ранее значения или добавить новые. Для добавления новых значений следует с помощью мыши выбрать пустую строку в иерархии нужной характеристики и для нее выбрать из справочника значение.
    С вложенными При установке галочки на некотором значении, в качестве значения характеристики при формировании отчета будет учитываться не только само указанное значение, но и все более частные для него значения. В противном случае в качестве значения характеристики будет считаться только само указанное значение.
    Исключить При установке галочки на некотором значении, это значение будет исключено для выбранной характеристики при выполнении отчета.

    Кнопки диалога:
    Кнопка Название Функция
     
    Вверх/Вниз Изменение последовательности характеристик .
    Изменить Позволяет добавить новые значения характеристики в отчет.
    Удалить Удаляет значение характеристики.
    Сохранить Сохраняет внесенные в настройки отчета изменения.
    Выйти Выход из диалога.

    12.2.8 Операция "Настройка печати надбавок по ШР" PRO

    Вызов PRO:
    По кнопке из диалога "Печать штатного расписания", который вызывается по кнопке из диалога "Менеджер штатного расписания" при печати следующих отчетов:
  • ШР для подразделения (с надбавками);
  • ШР для подразделения (ТЗ);
  • ШР по видам персонала.
  • При вызове печати штатного расписания с надбавками предоставляется возможность распределить печать надбавок по колонкам отчета, используя диалог настройки печати надбавок отчета.
    Для вызова диалога необходимо в соответствующем диалоге печати ШР выбрать кнопку "Настройка отчета", если она предусмотрена для этого отчета.



    Рисунок 12.2.7. Настройка печати надбавок ШР

    Столбцы таблицы:
    Столбец Назначение
    номер колонки В этом поле отражаются только колонки отчета, содержащие сведения о надбавках.
    название колонки В это поле заносится название, которое будет печататься в соответствующей колонке отчета.
    надбавка В этом поле отражается список надбавок, известных в системе.
    печатать в колонке В этом поле выбирается, в какой колонке отчета будет печататься данная надбавка. Если надбавка не отнесена ни к одной колонке, она печатается в колонке "другие надбавки".

    После сохранения сформированной настройки, значения выбранных надбавок каждой колонки для отчета будут суммироваться, и результат будет печататься в соответствующей колонке отчета.

    12.3 Настройки системы

    12.3.1 Настройка запуска программы

    Назначение:
    Служит для настройки параметров инициализационного файла, таких как путь к Модели и пользователь по умолчанию.

    Вызов:
    Меню → Сервис → Администрирование → Настройки запуска программы.



    Рисунок 12.3.1. Настройки запуска программы

    12.3.2 Склонения для печати

    Назначение:
    Для печати отчетов в виде, принятом на предприятии, используются имена объектов и некоторых значений характеристик в разных падежах. В связи с этим, при вводе нового имени (прием нового сотрудника, создание нового подразделения, ввод новой должности) следует ввести для этого имени все падежи. Ввод падежей для имени осуществляется в операции «Настройка склонений для печати».

    Вызов:
    Персонал-Биз Персонал-Про
    Меню → Сервис → Склонения для печати.
    По кнопке Склонение из диалога Справочник должностей.
    По кнопке Склонения для печати на Панели инструментов. -

    При выборе операции "Склонения для печати" система предлагает диалоговое окно для ввода имени в разных падежах (см. рисунок 12.3.2).



    Рисунок 12.3.2. Склонение имен

    Левая панель диалога представляет собой список идентификаторов. Правая часть диалога представляет собой поля для ввода нового идентификатора и имени в различных падежах. Чтобы ввести новое имя, выберите с помощью мыши верхнюю строку в правой части диалога поля (Идентификатор) и введите в него имя точно так, как оно написано в системе. Затем введите значения в различных падежах, при этом текст в падежах определяется тем, как он должен выглядеть в печатных документах. После записи всех падежей для нового имени по кнопке "Изменить" можно внести это имя в систему. При этом система уточняет, стоит ли добавить введенную информацию. При ответе "Да" имя вводится в систему и отображается в списке на левой панели диалога. Соответственно по кнопке "Нет" информация занесена не будет. При открытии диалога он настроен на ввод нового имени.

    Система позволяет изменять и удалять имена, введенные ранее. Для изменения имени выберите на левой панели диалога имя, которое необходимо изменить. При этом в полях правой части диалога отобразятся все падежи данного имени. Проведите необходимые изменения и по кнопке "Изменить" введите измененную информацию. Система потребует подтверждение на проведение изменений. Аналогично, выбрав на левой панели имя, его можно удалить по кнопке "Удалить". Система потребует подтверждение на удаление. При удалении имени оно удаляется из списка склонений со всеми падежами.

    Рекомендации.
    Задавая склонения возможно полностью изменить печать, например, можно ввести склонения для идентификатора "без разряда" как "б/р" и т.п.

    Поля диалога:
    Поле Назначение
    Файл В этом информационном поле указывается файл с настройками.
    Идентификатор Из справочника выбирается имя объекта, для которого необходимо задать падежные окончания.
    Именительный В эти поля вносятся формы данного имени в соответствующем падеже.
    Родительный
    Дательный
    Винительный
    Творительный
    Предложный
    Примечание: см. используемые в таблице символы.

    Кнопки диалога:
    Кнопка Название Функция
    Изменить Служит для удаления имени из справочника.
    Удалить При нажатии осуществляется поиск сотрудников по заданным параметрам.
    Выход Выход из диалога.

    12.3.3 Импорт данных

    Назначение:
    Система обеспечивает импорт данных из файлов в формате Microsoft Excel (CSV).

    Вызов:
    Меню → Сервис → Настройки → Импорт данных.

    В результате выполнения команды пользователю предоставляется диалоговое окно "Импорт данных" (рисунок 12.3.3).



    Рисунок 12.3.3. Импорт данных

    В поле "Импортировать данные из" необходимо выбрать файл, содержащий данные для импорта. Импорт может быть осуществлен следующих данных:

    • справочник должностей;
    • структура предприятия;
    • личные данные сотрудников;

    При импорте "справочника должностей" система обрабатывает следующие поля файла данных:

    • "*название должности"
    • "категория"

    При импорте "структуры предприятия" система обрабатывает следующие поля файла данных:

    • "*наименование общепринятое"
    • "входит в состав"
    • "наименование полное"
    • "наименование краткое"
    • "номер"

    При импорте "личных данных сотрудников" система обрабатывает следующие поля файла данных:

    • "*Фамилия Имя Отчество или Фамилия"
    • "имя"
    • "отчество"
    • "пол"
    • "дата рождения"
    • "паспорт серия"
    • "паспорт номер"
    • "паспорт учреждение"
    • "паспорт дата выдачи"
    • "почтовый индекс"
    • "адрес"
    • "*дата оформления на работу"
    • "дата приказа об оформлении на работу"
    • "номер приказа об оформлении на работу"
    • "вид найма"
    • "период найма"
    • "дата начала непрерывного стажа"
    • "номер страхового свидетельства"
    • "номер ИНН"
    • "табельный номер"
    • "последнее главное назначение"
    • " период назначения с"
    • " период назначения по"
    • " вид назначения"
    • " статус"
    • " место работы"
    • " должность/профессия"
    • " тарифный разряд/ПКГ"
    • " кол-во ставок"
    • " вид оплаты"
    • " оклад"
    • " приказ номер"
    • " приказ дата"
    Примечание: поля с "*" обязательны для импорта данных.

    После выбора файла импорта и указания типа данных в файле необходимо проставить соответствие между идентификаторами в системе и полями в файле данных. Для этого необходимо щелкнуть мышью в колонку рядом с названием идентификатора в системе и выбрать из появившегося списка полей в файле импорта соответствующее поле. После простановки всех соответствий нажмите кнопку "Импорт". В процессе осуществления импорта данных будет выдана трассировка сообщений о результатах импорта по каждой строке файла данных. Результат импорта данных можно сохранить, нажав кнопку "Сохранить", или "Отменить", если при импорте были существенные ошибки. При отмене импортирования данных результат импорта в системе не сохраняется.

    Рекомендации:
    Перед импортом данных обязательно создайте текущий "архив Модели".

    12.3.4 Копирование файлов

    Назначение:
    Для копирования файлов с серверной части на клиентскую и обратно используется диалог "Копирование файлов". Данный диалог может использоваться для обновления клиентской части. Также имеется возможность скопировать файл формы (*.frm) с сервера, отредактировать его на клиентской части и затем скопировать обратно на сервер для общего пользования.

    Вызов:
    Меню → Сервис → Настройки → Копирование файлов.

    При выборе операции система предлагает диалоговое окно файлового менеджера (см. рисунок 12.3.4). Для копирования выделить файл на соответствующей панели и нажать и .



    Рисунок 12.3.4. Диалог "Копирование файлов"

    Кнопки диалога:
    Кнопка Название Функция
    Обновить Служит для обновления данной панели.
    Новая папка Служит для создания новой папки.
    Удалить Служит для удаления выбранного объекта.
    Копировать Служит для копирования файла с клиентской части на серверную.
    Копировать Служит для копирования файла с серверной части на клиентскую.

    12.3.5 Настройка левой панели

    Персонал-Биз BIZ

    В версии "Персонал-Бизнес" настройки левой панели жёстко зафиксированы, то есть изменять состав справочников не допускается.
    Переключение осуществляется нажатием на закладки внизу левой панели (см. рисунок 12.3.5).



    Рисунок 12.3.5. Переход между панелями

    Персонал-Про PRO

    Назначение:
    Операция "Настройка левой панели" позволяет настраивать отображение информации на панели объектов, а также вводить некоторую информацию, которая будет принята по умолчанию.

    Вызов PRO:
    Меню → Сервис → Настройки → Настройка левой панели .

    При выборе операции система предлагает диалоговое окно для настройки системы (см. рисунок 12.3.6).



    Рисунок 12.3.6. Настройка левой панели

    Для того, чтобы нужная закладка была отображена на панели, необходимо пометить ее крестиком. Для изменения порядка закладок на существующей панели используйте кнопки .
    Чтобы удалить существующую панель, нажмите кнопку . Система потребует подтверждения на удаление. После нажатия кнопки "ОК" выбранная панель объектов будет удалена из системы.

    Кнопки диалога:
    Кнопка Название Функция
    Обновить Обновляет содержимое окна
    Создать Служит для создания новой панели.
    Изменить Служит для изменения панели.
    Удалить Удаляет существующую панель.
     
    Вверх/вниз Перемещают выбранный справочник в соответствующем направлении.
    Сделать панель активной Служит для сохранения порядка справочников.
    Выход Закрытие диалога «Настройка левой панели».

    12.3.6 Настройка нумераторов

    Назначение:
    Система позволяет создавать и настраивать для фирм и документов линейные нумераторы (то есть без формул, работающий по простому алгоритму n=n+1).

    Вызов:
    Меню → Сервис → Настройки → Настройка нумераторов.

    При выборе операции система открывает менеджер нумераторов (см. рисунок 12.3.7).



    Рисунок 12.3.7. Настройка нумераторов

    Нажать для создания нового нумератора, ввести его название, ввести начальное значение и нажать для сохранения изменений.

    Для привязки нумератора к фирме необходимо открыть её головную карточку, перейти к закладке "реквизиты фирмы", в режиме редактирования нажать правую кнопку мыши, выбрать в меню Добавить параметр, выбрать "нумератор", затем нажать на поле "тип нумератора" и выбрать из списка один из базовых или вновь созданный нумератор.

    Если при отказе от номера одним пользователем другой пользователь уже успел выбрать следующий номер, этот (первый) номер попадает в свободные номера. Эти номера можно присвоить впоследствии вручную.

    Столбцы таблицы:
    Столбец Назначение
    # Нумератор В этом поле указывается имя нумератора.
    Текущее значение При использовании нумератора в этом поле будет отражаться текущий номер последнего зарегистрированного документа (приказа).
    Свободные номера При необходимости зарегистрировать приказы с номерами меньше текущего номера, в это поле вводятся эти номера через запятую. При регистрации приказов эти номера будут использованы в первую очередь.

    Кнопки диалога:
    Кнопка Название Функция
    Перегрузить Перегружает содержимое диалогового окна.
    Создать Создает новое значение в справочник, на котором стоит курсор.
    Изменить Изменяет значение справочника или название справочника, на котором стоит курсор.
    Удалить Удаляет значение, на котором стоит курсор из справочника.
    Сохранить Сохраняет изменения в справочнике.
    Выход Выход из диалога.

    12.3.7 Создание нового отчета

    Назначение:
    Для создания собственных отчетов в программе предусмотрен универсальный шаблон отчетов "frmPrsn.frm", который содержит более 150 различных параметров. На основании этого шаблона Вы можете создать собственный отчет с требуемыми Вам параметрами и назначить ему вызов отчета при помощи операции "Создание нового отчета".

    Вызов:
    Меню → Сервис → Настройки → Создание нового отчета.

    При выборе операции система предлагает диалоговое окно для настройки нового отчета (см. рисунок 12.3.8).



    Рисунок 12.3.8. Создание нового отчета

    Поля диалога:
    Поле Назначение
    Название отчета В это поле заносится название, которое будет присвоено отчету в системе. Название отчета должно содержать путь к папке, в которой будет создан отчет.
    Файл формы В этом указывается файл формы отчета созданный на основании универсальной формы "frmPrsn.frm".

    Кнопки диалога:
    Кнопка Название Функция
    Выбрать отчет Служит для выбора файла отчета.
    Выбрать форму Служит для выбора файла формы.
    Сохранить Сохранение нового отчета в системе.
    Выйти Выход из операции без сохранения.

    12.3.8 Универсальный импорт из Excel

    Назначение:
    Операция предназначена для загрузки таблиц из Microsoft Excel в модель данных, что особенно актуально на начальном этапе работы с системой.

    Вызов:
    Для выполнения импорта на левой панели перейти к закладке "Управление" и выбрать UC Команда → UC Команда Адм → uc адм Импорт (рис.12.3.9.1). Откроется диалог "Импорт данных" (рис.12.3.9.2).
    Для настройки шаблонов универсального импорта на левой панели перейти к закладке "Настройки", выбрать шаблон → шаблон импорта и нажать правую кнопку мыши (рис.12.3.9.3). Выполняется с правами «название_права» (может быть перенастроена - делегирована требуемым ролям и пользователям).



    Рисунок 12.3.9.1. Универсальный импорт из Excel



    Рисунок 12.3.9.2. Диалог "Импорт данных"



    Рисунок 12.3.9.3. Настройка шаблонов универсального импорта из Excel

    Пусть имеется исходный файл Microsoft Excel следующего содержания:

    Ниже описана последовательность действий для создания соответствующего шаблона импорта для этого файла:

    1. Настроить соответствие колонок импорта и полей ввода:
      Name(1) = наименование общепринятое
      Comment(2) = код материала/код1
      USD (6) = цена установленная/цена
      Группа (7) = тип материала
      Полное наименование (8) = наименование дополнительное
    2. Cоздать шаблон, для чего в контекстном меню на рис.12.3.9.3 выбрать Новый шаблон.
    3. Указать наименование шаблона (рис.12.3.9.4).
    4. Выбрать класс объектов, которые будут импортироваться (рис.12.3.9.5).
    5. Добавить необходимые закладки (рис.12.3.9.6-12.3.9.7).
    6. В соответствующую закладку добавить поля для импорта нажатием кнопки (+) на клавиатуре NumLock (рис.12.3.9.8).
    7. Нажать →Alt+F10← и указать свойства полей импорта (рис.12.3.9.9).
    8. Добавить остальные поля (рис.12.3.9.10), указывая их начальные значения (рис.12.3.9.11-12.3.9.12).



    Рисунок 12.3.9.4. Создание шаблона



    Рисунок 12.3.9.5. Выбор класса объектов



    Рисунки 12.3.9.6-12.3.9.7. Добавление закладки

    При выборе операции система предлагает диалоговое окно для настройки нового отчета (см. рисунок 12.3.9).



    Рисунок 12.3.9.8. Добавление полей в шаблон



    Рисунок 12.3.9.9. Свойства полей импорта



    Рисунок 12.3.9.10. Добавление последующих полей



    Рисунок 12.3.9.11. Указание начальных значений



    Рисунок 12.3.9.12. Указание начальных значений

    12.4 Обслуживание модели

    Вызов:
    Меню → Сервис → Обслуживание модели.

    При выборе этого пункта меню появляется окно (см. рисунок 12.4.1) с перечнем команд по обслуживанию модели.



    Рисунок 12.4.1. Меню "Обслуживание модели"

    Перечень команд:
    Закрыть-Открыть Открытие или Закрытие модели. Часть операций может быть выполнена только на закрытой модели.
    Обновить Вызывает диалоговое окно, в котором необходимо выбрать обновление для модели.
    Проверить Осуществляет проверку целостности и корректности модели.
    Реставрировать Производит восстановление модели после сбоев. Операция может быть выполнена только на закрытой модели.
    Удалить Вызывает диалог "Удалить из модели".
    Обновить клиента Обновляет клиентскую версию в соответствии с последними изменениями на сервере.

    12.4.1 Закрыть-открыть модель

    Назначение:
    Часть операций может быть выполнена только на закрытой модели. Данная команда позволяет закрыть модель для выполнения команды "Реставрировать" и затем вновь открыть модель без выхода из программы.

    При помощи данной команды, можно переключиться на другую модель. Для этого необходимо в начале закрыть существующую модель, затем изменить путь к модели в диалоге «Настройка системы» и потом открыть модель.

    Вызов:
    Меню → Сервис → Обслуживание модели → Закрыть-Открыть.

    12.4.2 Обновить модель

    Назначение:
    В системе реализован механизм, обеспечивающий динамическое расширение функций системы без ее замены. Дополнительные функции описываются в специальных файлах, которые можно зарегистрировать в системе при помощи этой команды. Данная команда вызывает стандартный диалог открытия файла, в котором необходимо выбрать файл обновления для модели.

    Вызов:
    Меню → Сервис → Обслуживание модели → Обновить.

    12.4.3 Проверить модель

    Назначение:
    В системе содержатся средства проверки целостности и корректности модели. В случае наличия ошибок в Модели система выдаст соответствующее предупреждение. В большинстве случаев достаточно выполнить операцию "Реставрировать".

    Вызов:
    Меню → Сервис → Обслуживание модели → Проверить.

    Если в Модели содержатся некорректные данные или есть поврежденные файлы, то будет выдано соответствующее предупреждение (рисунок 12.4.2)



    Рисунок 12.4.2. Сообщение, выдаваемое системой.

    В случае появления такого предупреждения рекомендуется выполнить данную команду для обнаружения возможных повреждений.

    12.4.4 Реставрировать модель

    Назначение:
    В случае выдачи диагностических сообщений в процессе выполнения команды "Проверить" необходимо для исправления модели выполнить данную команду. Для этого в начале закройте модель при помощи команды "Закрыть-Открыть", а затем выполните данную команду.

    Вызов:
    Меню → Сервис → Обслуживание модели → Реставрировать.

    12.4.5 Удалить из модели

    Назначение:
    Команда "Удалить" (см. рисунок 12.4.3) позволяет "физически" удалить данные из системы.



    Рисунок 12.4.3. "Удалить из модели".

    Вызов:
    Меню → Сервис → Обслуживание модели → Удалить.

    Кнопки диалога:
    Кнопка Название Функция
    Перегрузить Происходит проверка вхождения данной сущности в описания других объектов.
    Восстановить Снимает пометку на удаление с данной сущности.
    Удалить Удаляет сущность из системы только в том случае, если она не входит в описания других объектов.
    Выход Закрытие окна «Удалить из модели».

    Процесс удаления состоит из 3-х этапов.
    На первом этапе необходимая сущность должна быть помечена на удаление в одном из справочников (Справочник объектов или Справочник характеристик).
    На втором этапе осуществляется проверка вхождения данной сущности в описания других объектов. Операция проверки осуществляется автоматически при загрузки диалога "Удалить из модели". В результате система выдаст список объектов, в описании которых присутствует данная сущность.
    На третьем этапе происходит "физическое" удаление. Удаляется сущность из системы только в том случае, если она не входит в описания других объектов. Выполняется в диалоге "Удалить из модели", путем нажатия кнопки "Удалить". Система потребует подтверждения данной операции.

    12.4.6 Обновить клиента

    Назначение:
    Команда служит для принудительного обновления клиентской части системы.

    Вызов:
    Меню → Сервис → Обслуживание модели → Обновить клиента.

    12.5 Архив модели

    Назначение:
    Система позволяет сохранять текущее состояние Базы Знаний в архиве и восстанавливать из архива сохраненное состояние.

    Во избежание потери данных в случаях внештатных ситуаций при работе ПК необходимо РЕГУЛЯРНО создавать Архивы данных Системы.

    Вызов:
    Меню → Сервис → Архив.

    При этом пользователю предоставляется диалоговое окно "Архив".

    Диалоговое окно "Архив" содержит панель инструментов (см. рисунок 12.5.1)



    Рисунок 12.5.1. Архив

    Кнопки диалога:
    Кнопка Название Функция
    Перегрузить Обновление данных в окне «Архив».
    Создать Создание нового архива.
    Открыть Восстановление информации из архива.
    Сохранить как Сохранение архива в файл.
    Загрузить Загрузка архива из указанного места.
    Отправить по почте Отправка указанного файла по электронной почте.
    Настройка Вызов диалога настроек системы.
    Выход Закрытие окна «Архив».

    На рабочем месте, настроенном как Архивариус, система при запуске проверяет, был ли создан архив за предыдущий день. Если таковой не создан, система предлагает провести архивирование.

    12.5.1 Создание архива

    Для создания нового архива с помощью левой кнопки мыши установите курсор в поле "архив" внизу окна и введите имя нового архива. Затем с помощью мыши нажмите клавишу "Создать" панели управления этого диалогового окна. Система потребует подтверждения создания архива. Для подтверждения выберите кнопку "ОК". По окончании создания архива система выдаст сообщение "Архив создан успешно". В списке архивов появится новый архив с указанным именем и датой создания.

    12.5.2 Восстановление из архива

    Для восстановления системы из архива выберите из списка архивов тот архив, который Вы хотите восстановить и выберите кнопку "Открыть". Система потребует подтверждения восстановления из архива. Для подтверждения выберите кнопку "ОК". Система загрузит сохраненный архив. При этом существовавшая версия системы будет утрачена.

    12.5.3 Восстановление из архива (на закрытой Модели)

    Восстановление архива может быть осуществлено на закрытой Модели в случае невозможности входа в систему по какой-либо причине. В этом случае при выполнении операции "Архив" вместо стандартного диалога архива будет предложен диалог выбора файла, в котором необходимо указать восстанавливаемый архив. Если операция пройдет успешно, то об этом будет выдано соответствующее сообщение.

    12.5.4 Удаление архива

    Для удаления архива выберите из списка архивов тот архив, который Вы хотите удалить и выберите кнопку "Удалить". Система потребует подтверждения удаления архива. Для подтверждения выберите кнопку "ОК". Система удалит архив из списка архивов.

    12.5.5 Сохранение архива

    Архив может быть сохранен в любую директорию, в том числе и на съемный диск, для сохранения архива на внешнем носителе. Для сохранения архива с помощью левой кнопки мыши выберите архив из списка архивов для его сохранения. Затем с помощью мыши нажмите кнопку "Сохранить как" панели управления этого диалогового окна. Будет предложено окно для указания пути сохранения файла. Укажите путь и выберите кнопку "Сохранить". По окончании сохранения архива система выдаст сообщение "Операция завершена успешно".

    12.5.6 Загрузка архива

    Архив может быть загружен в директорию текущих архивов системы из любой другой директории, в том числе и со съемного диска. По кнопке "Загрузка" система предлагает диалог для выбора файла архива. После выбора файла по кнопке "Открыть" файл будет скопирован в директорию архивов. По окончании выполнения операции система выдаст сообщение "Операция завершена успешно".

    12.5.7 Отправка архива по почте

    При необходимости архив может быть отправлен по почте для получения технической поддержки разработчика. По кнопке "Отправить по почте" система автоматически создаст письмо для отправки в службу поддержки с вложенным архивом. По кнопке "Отправить" письмо будет помещено в папку "Исходящие" почтовой программы для последующей отправки по команде "Доставить почту".

    Дополнение

    Для архивирования используется внешний архиватор "ARJ.EXE", который должен располагаться в директории системы "Персонал". Возможно, что при создании архива система продолжительное время не будет реагировать на Ваши действия. Это связано с неправильной конфигурацией архиватора. Для изменения настроек архиватора выберите его в панели задач Windows, войдите в настройки (выберите в контекстном меню команду "Свойства") и установите флажок "Автоматически закрывать по завершении работы". После этого система возобновит свои действия.

    Рекомендации

    Возможна следующая схема архивирования. В системе создаются архивы по дням недели (Понедельник, Вторник, ….) и каждый вечер, соответствующий архив перезаписывается. Раз в неделю (в последний рабочий день) соответствующий архив копируется на внешний носитель. Все архивы располагаются в директории "ARCHIV", под соответствующими именами.
    Проведение архивации необходимо перед существенными изменениями в Базе Знаний, например "Закрытие периода". Такая схема архивации обеспечит сохранность Ваших данных при различных сбоях в компьютере.

    12.6 Печать

    Система позволяет распечатать карточку так, как она изображена на экране: в виде дерева или в виде таблицы. Предварительно можно посмотреть, как будет выглядеть распечатанный вариант карточки. Прежде чем распечатать документ, необходимо его открыть (сделать активным), отредактировать документ средствами системы, а затем переходить к печати.

    12.6.1 Предварительный просмотр

    Вызов:
    Меню → Файл → Предварительный просмотр.

    В этом окне предварительного просмотра можно просмотреть документ в том виде, в котором он будет напечатан. Если Вас не устраивает вид распечатываемого документа, закройте окно предварительного просмотра, измените содержимое карточки документа или параметры страницы и вернитесь в режим предварительного просмотра.

    12.6.1.1 Меню режима предварительного просмотра

    В меню окна предварительного просмотра доступны следующие команды:



    Рисунок 12.6.1. Меню режима предварительного просмотра.

    Перечень команд:
    Печать отображает диалоговое окно "Печать"
    Следующая отображает следующую страницу;
    Предыдущая отображает предыдущую страницу;
    Две отображает две страницы одновременно;
    Увеличить увеличивает страницу документа;
    Уменьшить уменьшает страницу документа;
    Закрыть выход из предварительного просмотра.

    12.6.2 Параметры страницы

    Система позволяет изменять расположение текста документа на странице, задать верхний и нижний колонтитул, задать заголовок, установить шрифт при печати. Для этого необходимо перейти в режим редактирования параметров страницы.

    Вызов:
    Меню → Файл → Параметры страницы.

    Появившееся диалоговое окно имеет две закладки "Бумага" и "Заголовок".

    12.6.2.1 Закладка "Бумага"

    Для редактирования расположения текста на странице служит закладка "Бумага" (см. рисунок 12.6.2).
    Если вы печатаете документ на бумаге нестандартного формата, выберите из перечня "Размер бумаги" требуемый формат листа.
    Вы можете распечатать документ в книжной или альбомной ориентации. Документы, у которых ширина превышает длину, (как правило, отчеты) лучше распечатывать горизонтально. Для этого под надписью ориентация выберите "Альбомная".
    Вы также можете изменить границы текста, расположить его выше или ниже, сдвинуть вправо или влево на странице. Для этого определите значения соответствующих полей.



    Рисунок 12.6.2. Параметры страницы. Закладка "Бумага"

    12.6.2.2 Закладка "Заголовок"

    Для формирования заголовка текста, нумерации страниц, а также для выбора шрифта печати служит закладка "Заголовок" (см. рисунок 12.6.3).



    Рисунок 12.6.3. Параметры страницы. Закладка "Заголовок"

    Вы можете задать текст, который будет располагаться в верхней части документа и служить заголовком для распечатываемого документа. Для этого введите этот текст в нижнюю часть блока "Заголовок". В верхней части этого блока вы можете задать шрифт для печати этого заголовка.
    Вы можете задать нумерацию страниц документа, которая будет располагаться в верхнем правом углу документа. Она задается в нижней части блока "Нумерация". В верхней части этого блока можно задать шрифт для нумерации.
    Вы можете задать текст, который будет располагаться в нижнем левом углу документа.
    Для этого введите необходимый текст в нижнюю часть блока "Сноска". В верхней части этого блока вы можете задать шрифт для этого текста.
    При отсутствии текста в полях место под соответствующие поля не выделяется, и они не печатаются.
    Расположение текста в поле задается при помощи " " (пробелов).
    Верхний и/или нижний колонтитул могут содержать нумерацию страниц, дату печати. Для добавления этих данных, в соответствующую позицию вставьте специальную комбинацию символов:
    %d - текущая дата
    %p - номер страницы

    12.6.3 Печать документа

    Внимание: печать документа возможна только на открытой карточке.

    Вызов:
    Меню → Файл → Печать.

    или нажать соответствующую кнопку на панели инструментов. Диалоговое окно "Печать" (см. рисунок 12.6.4) позволяет выбрать тип принтера, тип выводимой на печать информации и количество необходимых копий. Выполните необходимые установки и нажмите клавишу "OK" после чего документ будет выведен на принтер.



    Рисунок 12.6.4. Печать документа

    Содержание | Наверх